To create any application on the JLupin Next Server, which uses library codes of the server, add the following dependencies:

All required libraries (as JAR files) are available here --> jlupin-all-assembly-1.3.0.jar

Add libraries above by following commands (install MAVEN correctly before this) :

mvn install:install-file -DgroupId=com.jlupin -DartifactId=jlupin-all-assembly -Dversion=1.3.0 -Dpackaging=jar -Dfile=jlupin-all-assembly-1.3.0.jar

Add the following dependencies to Your project as maven (change version to proper number):

<dependency>
  <groupId>com.jlupin</groupId>
  <artifactId>jlupin-all-assembly</artifactId>
  <version>1.3.0</version>
  <scope>provided</scope>
</dependency>

! Important note: If You write only client code which connect to JLupin and invoking remote method by JLupin`s load balancer (from external servers for example) use only jlupin-client-assembly-1.3.0.jar.

That library You can download here --> jlupin-client-assembly-1.3.0.jar

Maven install command:

mvn install:install-file -DgroupId=com.jlupin -DartifactId=jlupin-client-assembly -Dversion=1.3.0 -Dpackaging=jar -Dfile=jlupin-client-assembly-1.3.0.jar

Maven dependency:

<dependency>
  <groupId>com.jlupin</groupId>
  <artifactId>jlupin-client-assembly</artifactId>
  <version>1.3.0</version>
  <scope>provided</scope>
</dependency>

Other dependency that may be needed in development and running test process

<dependency>
    <groupId>org.springframework</groupId>
    <artifactId>spring-asm</artifactId>
    <version>3.1.3.RELEASE</version>
    <scope>provided</scope>
</dependency>
<dependency>
    <groupId>org.springframework</groupId>
    <artifactId>spring-beans</artifactId>
    <version>4.1.4.RELEASE</version>
    <scope>provided</scope>
</dependency>
<dependency>
    <groupId>org.springframework</groupId>
    <artifactId>spring-context-support</artifactId>
    <version>4.1.4.RELEASE</version>
    <scope>provided</scope>
</dependency>
<dependency>
    <groupId>org.springframework</groupId>
    <artifactId>spring-core</artifactId>
    <version>4.1.4.RELEASE</version>
    <scope>provided</scope>
</dependency>
<dependency>
    <groupId>org.springframework</groupId>
    <artifactId>spring-expression</artifactId>
    <version>4.1.4.RELEASE</version>
    <scope>provided</scope>
</dependency>
<dependency>
    <groupId>org.springframework</groupId>
    <artifactId>spring-jdbc</artifactId>
    <version>4.1.4.RELEASE</version>
    <scope>provided</scope>
</dependency>
<dependency>
    <groupId>org.springframework</groupId>
    <artifactId>spring-orm</artifactId>
    <version>4.1.4.RELEASE</version>
    <scope>provided</scope>
</dependency>
 <dependency>
    <groupId>log4j</groupId>
    <artifactId>log4j</artifactId>
    <version>1.2.17</version>
</dependency>
 <dependency>
    <groupId>junit</groupId>
    <artifactId>junit</artifactId>
    <version>4.8.1</version>
    <scope>test</scope>
</dependency>